
HOW TO FORMAT A BOOK FOR SELF-PUBLISHING 

by Patrik Martinet 

 

Hello! Welcome to my illustrated book formatting guide! Let me start off by saying that this guide is not 
intended to be all-inclusive and will most certainly not cover everything or solve every possible issue. It is 
merely a guide I developed using the steps I have personally followed for formatting print and e-book versions 
of my own books. However, using these steps, you should be able to successfully create professional looking 
books. Using these steps, which I have refined throughout my own self-publishing journey, I have produced and 
published several books now available in both print and e-book. My hope is that this guide alleviates some of 
the headache I personally experienced learning how to format my books for self-publishing. 

 

Please note: these instructions are for Windows operating system using Microsoft Word. Results will vary if 
you format using a different platform. 

 

That said, let's start formatting! I'll start with how to format a print book. If you are interested in formatting e-
books, skip on ahead to that section later in the guide. 

 

PRINT BOOK FORMATTING 

 

1. On the Home menu, paragraph block, turn on 
paragraph marks and other hidden symbols 
 
 
 
 

2. Set document image quality: if you are going to have images in your book, you need to set up the 
document so Word keeps your high-quality images. If you don't prevent Word from compressing 
images, your high-resolution images will end up low-resolution. 

a. Select File menu, Options, Advanced. 
b. Scroll down to Image Size and Quality. 
c. Check "Do not compress images in file" 
d. For Default resolution select "High 

fidelity" 
e. Click OK 

 

 

 

 



3. Set page size. Determine desired size of book. This is the actual 
physical size you want the book to be when you hold it in your 
hand. 

a. Select the Layout menu, select size 
b. If your specific size isn't listed, select more paper sizes 

at the bottom of the drop-down menu 
c. Under paper size, enter desired width and height 

i. Make sure at bottom of menu it says "apply to 
whole document". 

 

 

 

4. Set margins. 
a. In the same menu for setting page size, set desired 

margins. 
b. First, select the multiple pages menu and set mirror 

margins. 
i. You will notice that even and odd pages will 

have opposite margins.  
c. Then select top, bottom, and inside margins 

i. Note: inside margins are the same as gutter 
margins. Leave gutter margins set to 0. The 
reason for inside margins (or gutter margins) is 
because you don't want your text buried down in 
the spine. I have a pet peeve of cracking the 
spine of a book to read it and this can easily 
happen to books with a high page count. 
Adjusting the inside margin can help reduce this 
tendency. 

ii. For my books of 350-400 pages, I use .6" for top, bottom, and outside margins and .8" for 
inside margin. But this is totally personal preference. 

 

 

 

 

 

 



 

5. Add front matter 
a. Title page 
b. Copyright 
c. Contents 
d. Acknowledgements (can be at end as well) 
e. Dedication 
f. Maps (at least in my case, being a fantasy author) 
g. Title 

i. This is a repeat of just the title if you desire. See your favorite book for example 
h. Note: insert a page break on each page 
i. Note: if you want all of the front matter to be on the same side (i.e. right hand page) enter an 

extra page break to create a blank page on the left. 
j. Note: front matter can also be back matter. It is really your preference. I.e. For example, 

acknowledgments could be at the end of the book instead. 
6. Add back matter 

a. About the Author, index, glossary, or any other page you want or need. 
b. The process is the same as front matter. 

 

Note: the next few steps will set the formatting for the entire book. Then we will go back and adjust specific 
areas as needed. 

 
 

7. Select the entire document and set line spacing 
a. Line spacing is found in the paragraph block of the Home 

menu. 
b. Open the line spacing drop-down menu and select line 

spacing options 
c. In the paragraph window that opens, ensure the before 

and after spacing are both set to zero 
d. Select line spacing to "exactly"; chose desired spacing. 

Try starting with 15pt and adjust up or down to achieve 
desired spacing. 

 

 

 

 

 

 

 

 



 

8. With entire document selected, change page alignment to justify. 
a. Page alignment options are found in the paragraph block of the Home menu. 
b. Note: this will justify the entire document but we'll make specific alignment changes in 

subsequent steps. 
 

 
 

9. With entire document selected, set desired font and font size. 
a. Choose the actual desired font and font size desired in the text of the book. Later we will adjust 

specific sizes for other items later. 
10. If you don't already have paragraph indentation set, select entire document and set desired paragraph 

indentation. 
a. You can use the ruler at the top of the document or adjust it in the paragraph menu where you 

adjusted the line spacing. 
b. I personally use .25". However, this is purely a personal preference. 

 

c. After you set indentation for the entire document, you will need to manually remove indentations 
where you don't want them 

i. Change indentation of front matter, back matter, chapter titles, scene breaks (anything 
you don’t want indented) back to zero. For me, this includes the first paragraph of each 
chapter, as I prefer the first paragraph of each chapter to not be indented. If you use scene 
breaks, it would also include the first paragraph of each scene. 

ii. Indents can be easily deleted by placing cursor at the beginning of the item you don't 
want indented and pressing backspace. 

d. While I am taking out the indents where I don’t want them, I am also centering that which I want 
centered, such as the front matter, chapter titles, and section breaks. Anything you previously had 
centered will now be justified from the previous step of justifying the document 

i. This process is easy if each chapter title is a heading as you can use the navigation pane 
to quickly click to each chapter. To find scene breaks I use the find function (Ctrl F) to 
find each scene break (i.e * * *, or whatever symbol you use.) If your chapters aren't 
currently headings that's fine as we'll format them shortly 

ii. Note: be sure to remove the indentation from item before centering it. If you don’t 
remove the indentation it will center with the indentation still in place, which will make 
the center skewed to the right. 

 
*Incorrect chapter title indentation*   *Correct chapter title indentation* 

  

 



 

 

 

11. Each individual front matter page and each chapter should end with a page break. 
a. To prevent erroneous blank pages in your finished book, ensure the page break is inserted on the 

same line as the last line of text for the section. If there is even one blank line after the last line of 
a chapter you may end up with an erroneous blank page if the text goes to the last line of a page. 
With the show/hide paragraph marking feature turned on, you should see the page break 
markings. 

b. If you don't already have page breaks, enter one at the end of each front matter page, back matter 
page, and chapter using the Insert menu, Page Break. Or press Control+Enter. 
 

    Title page with page break 

 

Incorrect page break placement        Correct page break placement 



 

 

12. Format your chapter titles as a Heading. 
a. Format the font of the chapter title 

i. If you don’t already have your chapter titles set as Headings: 
1. Place the cursor on your first chapter title (or prologue if you have one) 
2. In the styles block of the Home menu, select Heading 1. If by default it isn't in 

your gallery, click the button on the bottom right of the styles block, select 
Heading 1, click the down arrow next to it and add it to your gallery. 

 

3. Set the desired font, size, and bold, italic, etc. 
4. Open the paragraph menu by clicking the button in the bottom right corner of the 

Paragraph block on the Home menu. 
 

 
5. Choose the desired spacing before your chapter title. Choosing spacing prior to 

your chapter title will determine how far down the page you want your chapter to 
begin. If you want it to begin right at the top of the page, the spacing should be 
zero. 



 

 
 
 
 
 
 
 

ii. After you have all the formatting set for your chapter titles, right click on Heading 1 in 
the Styles block and update Heading 1 to match selection 
 

 
 

iii. Note: If for some reason the chapter title doesn't drop down on the page to the desired 
spacing add one blank line above the chapter title by placing the cursor just before the 
title and press Enter. The chapter title should drop down to desired spacing.  

b. Click through document, place cursor on each chapter title, and select Heading 1. The chapter 
title should now match your desired Heading and spacing. 

i. Repeat for each chapter title. 
c. Enter desired spacing after the chapter title before the beginning of the text. Two blank lines 

seems about right to me. Again, this is preference. 

 

13. Format front matter 
a. Format the title at the beginning a Heading 1. The title will adjust to your preset Heading, but 

you can adjust it to your desired spacing now. 
i. Adjust the font size and spacing before title to desired amount so that all the title 

information is centered top/bottom on the page. Use the same procedure for setting 
spacing as you did for chapter titles. However, don't update Heading 1 to this new setting. 

ii. Set spacing and font size for any other title info (series name, book number, author name, 
etc.). 



b. Fill out the copyright page as desired.  
i. Set font size and center text. 

c. Set the title of each subsequent front matter page (i.e. acknowledgments, map, table of contents, 
etc.) Heading 1 

i. Fill out acknowledgments as desired 
1. Any text should be set to justified 

ii. If you have a map, set the title of your map page to 
Heading 1 

1. After title, add a return or two as desired for 
spacing between title and the actual map 

2. Insert map. 
3. Center picture on page 
4. Note: the process for entering pictures 

anywhere else in the book is the same. You 
can use the Layout Options menu to configure how your picture behaves with 
other text in the document. 

 

iii. Title (the book title is often repeated on the last page just before the book begins) 
1. Highlight title and select Heading 1 
2. Adjust size of font and spacing before the title as desired. Remember spacing 

before is found by opening the Paragraph pop-up menu in the paragraph block. I 
used 210pt before to center my title on the page. 

 



d. Create Table of Contents, if desired. 
i. Locate Table of Contents under the References menu, select desired Table of Contents 

format. 
 

 
 

ii. After you create table of contents, highlight and adjust font, size, and spacing as desired. 
iii. If there are any entries you don't care to have in your contents you can highlight and 

delete. 
iv. If you make any changes to the content of the document after you create your contents, at 

the top of the contents table you can always update the page numbering as desired. 

 

 

e. You want your front matter pages to all be on the right side of the book (odd pages). To do this, 
insert a blank page between each front matter page. Each front matter item should begin on the 
right-hand side of the book (i.e. odd page). If the front matter item (such as acknowledgments) is 
more than one page that is fine. The next item can begin directly on the next page. But if the item 
is only one page (on the right hand side of the book) the next page (the left hand side) should be 
blank.  

14. Format back matter 
a. Same procedure as front matter 

15. Now for the fun part! Formatting page numbers! 
a. Open the header/footer menu by double clicking on either the header or the footer on the first 

page of the document. 
b. Ensure that in the options tab that "different first page" and "different odd and even pages" are 

NOT checked. 
 

 
 

c. Click the page number drop-down menu and select where you would like your page number 
inserted. Top? Bottom? Your choice. 



 

i. Make sure there are no returns above or below your page number. 
 

 
 

ii. Set spacing from top or bottom of page, depending on if page number is at the top or 
bottom 
 

 
 

d. If you want the even and odd pages to display different information (for instance, book or 
chapter title on the even pages and the authors name on the odd pages) select the "different odd 
and even pages" option. 
 

 
Note: if after selecting "Different Odd & Even Pages" the page number on the even side 
disappear, simply reselect the Page Numbers drop-down menu and reselect page number in 
desired location. 
 
This is what the actual book should look like. Odd pages on the right and even pages on the left. 
 



 
 

e. Manually type in the desired information for your even and odd pages 
f. Select font and size of page numbers (verify both even and odd numbers are the same) 
g. Typically, the first page of chapters don't have page numbers. If this is something you want, now 

click the "different first page" option in the header/footer menu. You should see the page number 
on page one disappear. 
 

 
Page number 1 is gone! 

 
 
 
 
 
Chapter 1 still has a page number… don't worry. We'll get rid of it next using section breaks. 

 
 

h. Creating section breaks (Section breaks are necessary if you want the first page of each chapter 
to not have page numbers) 

i. Place cursor immediately after the page break on the last page of your front matter 
material. Since I want chapter 1 to begin on the right-hand page (odd page), I have a 
blank page at the end of my front matter.  



 

ii. Under the Layout menu, select "breaks" 
 

 

 

iii. Next, select "Next Page" 
 

 
 

Section Break entered 
 



 
 
The page number on the first page of chapter 1 are now gone! 
 

 
 

iv. Repeat on the last page of each chapter. (ensure cursor is immediately after the page 
break as shown above) 

 
 

i. Often times the front matter in books does not include page numbers. If you want to delete page 
numbers from front matter, open the header/footer on the first page of chapter (should be an odd 
number if on the right-hand page) and on the navigation block, deselect "Link to Previous". 
Repeat for the even page number as well (left-hand page). 
 

 
 

j. After both even and odd pages of chapter 1 have be unlinked, go to the page numbers (both odd 
and even) in the front matter and delete them. 
 
 
 
 
 
 
 
 
 



16. A little fine tuning 
a. Widow/orphan 

i. You want to have the text on every page come to the 
very bottom where you have your margin set. If you 
find that this isn't happening, it might be because of 
the widow/orphan setting. Highlight the entire 
document, open the paragraph settings pop-up 
menu, and toggle the widow/orphan setting on and 
then off. This should fix the problem.  

 

b. If you find that a chapter ends with only 1, 2, or even 3 lines on the last page of the chapter and 
you don't want all the white space, you can make a line spacing adjustment in the Paragraph pop-
up menu to bring those hanging lines up to the previous page. 

i. Highlight the last 2-3 pages of the chapter and make small, incremental line spacing 
adjustments until the dangling lines all move up to the previous page. For instance, if 
your line spacing is set to 15pt, with the last 2-3 pages highlighted, change the line 
spacing to 14.5pt. If that doesn't quite do it, reduce the line spacing to 14.4pt, then 14.3pt, 
etc. until the lines are all together. In the below example, a line-spacing of 14.2 moved 
the last three lines up to join the rest of the chapter and saved all the white space. 

 

 

c. Want drop caps for the first letter of each 
chapter? 

i. Place the cursor on the first line of a 
new chapter. 

ii. Select the Insert menu and in the text 
box find the "Add a Drop Cap" menu. 
 

 
 



iii. Select "Dropped" 
iv. In "Drop cap options" menu, you can adjust how many lines the first letter is dropped. I 

think it defaults to 3 lines. You can adjust it up or down as you prefer. In the example 
above I have it dropped 2 lines. 

v. Note: the drop caps function makes the first character of a paragraph larger. If the first 
character is a quotation mark because the chapter begins with dialogue as in the above 
example, you will need to delete the first quotation mark so the letter is dropped and not 
the quotation mark. I've checked other books that do this and this seems to be the proper 
way to format it. 
 

17. When you are all done formatting, hide paragraph marking 
a. Take a moment and look at your formatted book. Pay 

close attention to the fine details. Make sure 
everything is in place. 

 

18. Print document to PDF 
a. File, Print 
b. For printer, select "Microsoft Print to PDF" 
c. Note: if your page size is unique and Word doesn't recognize it, it won't print to PDF properly. If 

this is the case, it is possible to change the registry to create custom page sizes. Google can help 
with this. 

d. View PDF and make sure everything is perfect. This PDF is literally the inside of your book. The 
book will print exactly as it appears in the PDF. Look everything over with a fine-toothed comb. 
Look for anything that be out of place. For example, I do a word search for "chapter" and make 
sure the line spacing on every chapter title is exactly the same. If you click through the chapters 
they should be on the same line throughout the book. They may move side to side depending on 
whether they are on the even or odd pages (remember mirror margins?) but should all start on the 
same line. If they don't there might be an extra space before the title that there shouldn't be. Are 
the page numbers correct? These are the types of things I look for. If you find any errors you can 
just make the changes on the Word document and then print it to PDF again. 

  



E-BOOK FORMATTING 

 

1. Turn on paragraph marking. 
 

 
 

2. Set document image quality: if you are going to have images in your ebook you need to set the 
document up so Word keeps your high-quality images. You don't want your images to end up getting 
compressed into low-quality images. 

a. Select File, Options, Advanced. 
b. Scroll down to Image Size and Quality. 
c. Check Do not compress images in file. 
d. For Default resolution select High fidelity. 
e. Click OK. 

 

f. Note: Apple has a max image size of 4 
million pixels for any internal images. If you 
are planning on publishing your book in 
Apple Books you need to make sure your 
images do not exceed 4 million pixels. To 
check this, right click on the image and open 
its properties. Click the details tab. Multiply 
the width times height (both given in pixels) 
for total pixel size. If it exceeds 4 million, 
you can adjust the size easily using MS 
Paint. In this example, the dimensions are 
1800 pixels X 2700 pixels. Total pixel size is 
4,860,000 pixels, which is too big. Open the 
picture in Microsoft Paint (or other photo editing software you may be familiar with) and adjust 
the pixel size. In paint, select "Resize", "Pixels", and ensure "Maintain aspect ratio" is checked. 
Then manually change either the Horizontal or Vertical pixel size (only change one and let the 
other change automatically to preserve aspect ratio) until their total equals 4 million or less. In 
this example, I change the Horizontal pixels to 1600 the vertical automatically changes to 2400. 
Combined, they total 3,840,000 pixels, which satisfies Apples requirement. Save this as a new 
file to use for Apple and preserve the original.  

 



3. Add front matter. 
a. Title page 
b. Copyright 
c. Contents 
d. Acknowledgements (can be at end as well) 
e. Dedication 
f. Maps (at least in my case, being a fantasy author) 
g. Title 
h. Note: insert a page break on each page 

4. Add back matter. 
a. About the Author 
b. Etc. 

5. Select entire document and set line spacing to single space. 
 

 
 

6. With entire document selected, change page alignment to justify. 
 

 
7. With entire document selected, set desired font. 

a. With an e-book you don't need to get fancy with the font. It's a personal choice, but I use Times 
New Roman. 

8. With entire document selected, set desired indentation. 
a. I personally use .25". However, this is purely a personal preference. 

 

 
 

b. This will indent the entire document. You will need to go through the document and remove 
indentations where you don't want them (i.e front matter, back matter, chapter titles, scene 
breaks, etc.). For me, this includes the first paragraph of each chapter, as I prefer the first 
paragraph of each chapter to not be indented. If you use scene breaks, it would also include the 
first paragraph of each scene. 



c. While I am taking out the indents where I don’t want them I am also centering that which I want 
centered, such as the front matter and the section breaks. Any previous centering you had will 
now be justified from previous step of justifying the document. 

i. This process is easy if each chapter title is a Heading as you can use the navigation pane 
to quickly click to each chapter. To find scene breaks I use the find function to find each 
scene break (i.e * * *, or whatever symbol you use). 

d. Note: for anyone who plans on uploading to Amazon Kindle directly, you will need to create a 
MOBI file. And MOBI files AUTOMATICALLY create an indent on the first line of every 
paragraph. So, if you do not want your first line indented, you will need to "trick" the MOBI file 
that you want a really really small indent. Changing indentation to zero will not work as MOBI 
will automatically create a .5" indentation. One way of tricking MOBI is to set the first line of 
each paragraph (or any line you don't want indented) to have an indent of .01" as opposed to .5". 
You will need to do this in all front matter and back matter text if you don't want your text 
indented. 

 
 

 
9. Each individual front matter page and each chapter should end with a page break. 

a. Important! To prevent erroneous blank pages in your finished ebook, ensure the page break is 
inserted on the same line as the last line of text for each chapter. If there is even one blank line 
after the last line of a chapter you may end up with a blank page in your ebook. With the 
show/hide paragraph marking feature turned on, ensure paragraph breaks are in the correct spot. 
 

 
 

 

  



10. Format your chapter titles as a Heading. 
a. Format the font of the chapter title. 

i. If you don’t already have your chapter titles set as Headings 
1. Highlight your first chapter title (or prologue if you have one). 
2. In the styles block of the Home menu, select Heading 1. If by default it isn't in 

your gallery, click the button on the bottom right of the styles block, select 
Heading 1, click the down arrow next to it and add it to your gallery. 

 

3. Set the desired font, size, and bold, italic, etc. 
4. Open the paragraph menu by clicking the button in the bottom right corner of the 

paragraph block on the Home menu. 
 

 
5. Choose the desired spacing before your chapter title. Choosing spacing prior to 

your chapter title will determine how far down the page you want your chapter to 
begin. If you want it to begin right at the top of the page, the spacing should be 
zero. 
 

 
 
 
 
 
 
 



ii. After you have all the formatting set for your chapter titles, right click on Heading 1 in 
the Styles block and update Heading 1 to match selection. 
 

 
 

iii. Note: If for some reason the chapter title doesn't drop down on the page to the desired 
spacing add one blank line above the chapter title by placing the cursor just before the 
title and press Enter. The chapter title should drop down to desired spacing.  

b. Click through document, highlight each chapter title, and select Heading 1. The chapter title 
should now match your desired Heading and spacing. 

i. Repeat for each chapter title. 
c. Enter desired spacing after the chapter title before the beginning of the text. Two blank lines 

seems about right to me. Again, this is preference. 
i. I also prefer a little more space between the chapter title and the beginning of the text so I 

add an extra return after the title. Two blank lines seems about right to me. Again, this is 
preference. 

11. Format front matter. 
a. Set the title to Heading 1 and then adjust the size and spacing before (in the paragraph pop-up 

window) to desired amount. 
i. I set my title at 18 font and 150pt before (may require a blank line prior to get proper 

spacing). 
ii. Set spacing and font size for any other info (series name, book number, author name, 

etc.). 
b. Fill out copyright page as desired. Set font size and center text. 
c. Set "acknowledgments" to Heading 1. 

i. Fill out acknowledgments as desired. 
ii. Any text should be set to justified. 

1. Remember, if you are going to upload directly to Amazon and don't want this 
portion indented, you need to indent the first line of each paragraph with .01" as 
instructed above. The same applies to all front matter you don't want indented. 

d. If you have a map, set the title of your map page to Heading 1. 
i. After title, add a return or two as desired. 

ii. Insert map. On the insert tab select picture. Locate picture on device and insert. 
iii. Center picture on page. 

e. Title 
i. Place cursor on title and set to Heading 1. 

ii. Adjust size and spacing as desired. Again, I prefer 18pt font and 150pt spacing above. 
(may require a blank line prior to get proper spacing) 

f. Create Table of Contents 
i. Now, go back to the table of contents and under the References menu, select desired table 

of contents format. 
 



 
 

ii. After you create table of contents, highlight and adjust font, size, and spacing as desired. 
iii. If there are any entries you don't care to have in your contents you can highlight and 

delete. 
12. Format back matter. 

a. Same as front matter. 
13. When you are all done formatting, hide paragraph marking. 

a. Take a moment and look at your formatted book. Pay 
close attention to the fine details. Make sure 
everything is in place. 

 

At this point, the formatting should be complete! Now we need to turn your Word document into either an 
EPUB or MOBI file. For this, we will use a program called Calibre, which can be downloaded for free at 
https://calibre-ebook.com/ . 

14. Open Calibre. 
a. Select Add Books. 

 

 
b. Locate formatted Word document on computer and select. The book will appear in the center of 

Calibre. 
 

 

 

c. Select Edit Metadata. 
 

 
 
 
 
 



i. Fill out Metadata as desired. 
1. Note the sorted Title and author. If the Title and Title sort aren't correct they will 

turn red. Same for Author and Author sort. 
2. Select Browse to change cover to load your ebook cover file. 

ii. When finished, click OK. 

 

d. Click Convert books. 
i. Verify Output format as EPUB or MOBI. 

ii. If you have any photos in your ebook, click "Page Setup". 
 

 



 

iii. Select "Generic e-ink HD". 

 
iv. Click Okay and Calibre will create your ebook . 

1. You will then see in the bottom right corner the job processing. When it finishes, 
click the click to open link to find the EPUB or MOBI file. 

15. Test your ebook! 
a. You can actually view your ebook right in Calibre, but I have found it to not be very helpful. I 

want to see what it actually looks like on a device. Fortunately, there are a couple ways to do this 
before you publish it and send it out into the wild. I'll cover both. 

b. For EPUB files: 
i. Click the "click to open" link to locate your ebook on your 

computer. 
ii. Email the EPUB file to yourself. 

iii. Open the email you sent yourself on your phone or tablet 
(iPad).  

1. If you're using an Apple device, open the EPUB file 
in BOOKs. 

2. If you're using an Android device, open the file in 
Google Play Books. 

iv. Flip through your ebook and look for any errors! 
v. This is a good time to see if you like the spacing of the book 

title and chapter titles. Also look for any blank pages. Hint: 
there shouldn't be any. If there are, you may have a page break where it shouldn't be. 
Also, click any images to open them and make sure you are satisfied with the resolution. 
It would be a shame to have really great photos only for them to end up grainy in your 
book. If they aren't high resolution you might have missed one of the steps above (setting 
image quality in Word or selecting Generic ink HD in Calibre.  

vi. Make any changes you need until you are completely satisfied. You can use Calibre to 
create as many books as you need until you have it perfect.  

c. For MOBI files (aka Kindle): 
i. I use a program called Send to Kindle. 

ii. Log into your KDP account and begin the ebook setup process. 
iii. After uploading your formatted Word document you then have the option to preview 

your ebook. I prefer the preview on your device option. 
iv. Click the MOBI link to download the ebook to your computer then locate the file on your 

computer. Right click on the downloaded MOBI file and select Send to Kindle. 
v. Ebook will shortly appear on your selected device. 


